Omezení rychlosti aktualizací Windows

Omezení rychlosti aktualizací Windows Mikrotik

V některých případech mohou aktualizace systému Windows nepříjemně vytížit konektivitu. A to především v sítích s velkým počtem počítačů může způsobovat problémy nebo snižovat komfort práce.

Řešení je omezit stahování dat ze serverů společnosti Microsoft na nějakou přijatelnou rychlost.

Detekce trafficu ze serverů Microsoft

Následující příkaz v zařízení MikroTik přidá Layer7 protokol, který rozpozná traffic ze serverů Microsoftu.

/ip firewall layer7-protocol
add name=MicrosoftUpdates regexp="^.+(update.microsoft|windowsupdate|download.microsoft|wustat|ntservicepack|update.microsoft.com|crl.microsoft.com|download.microsoft.com|office.microsoft.com|download.windowsupdate.com|windowsupdate.com|ntservicepack.microsoft.com|officeupdate.microsoft.com|stats.microsoft.com|v4.windowsupdate|v4.windowsupdate.microsoft.com|windowsupdate.microsoft.com|wustat.windows.com|test.stats.update.microsoft.com|.msu|.manifest|.mum).*\$"

Označení packetů

Nyní je třeba označit packety v IP > Firewall > Mangle.

/ip firewall mangle
add action=mark-packet chain=prerouting comment="ms list dst" layer7-protocol=MicrosoftUpdates new-packet-mark=ms passthrough=no

Omezení rychlosti

Označené packety už stačí pouze omezit pomocí Simple Queues.

/queue simple add max-limit=1M/1M name=MS packet-marks=ms target=0.0.0.0/0

Tímto způsobem je stahování aktualizací omezeno na 1 Mbit/s. Myslete ale na to, že používání Layer7 protokolů je poměrně náročné na procesor routeru a ne vždy je takovéto řešení vhodné.

Omezení aktualizací Windows

Více se o problematice dozvíte ve fóru Mikrotiku: forum.mikrotik.com/viewtopic.php?t=51802

Napsat komentář